miércoles, enero 05, 2011

JTS 1.11

En el caso de que alguien haya decidido empezar el año probando alguno de los últimos builds diarios de SEXTANTE, y lo haya hecho con gvSIG, habrá notado que SEXTANTE usa ahora la versión 1.11 de JTS, lo cual causa problemas y no arrancará correctamente el programa. Para solucionar esto, deben sustituirse dos ficheros de la carpeta de gvsig ([directorio de gvSIG]/bin/gvSIG/extensiones/com.iver.cit.gvsig/lib:

- bin/jts-1.9gvSIG.jar
- bin/jtsio-1.8.jar

En su lugar, se deben poner los correspondientes a la versión 1.11, que se han de descargar de la página de JTS, ya que no vienen con SEXTANTE (el primero de ellos sí, porque es necesario, pero el segundo no, ya que SEXTANTE no lo usa. No obstante, parece que algunas clases que están ahora en el primero estaban antes en el segundo, lo cual causa conflictos si no se sustituyen ambos).

Una vez hecho esto, no debería haber más problemas. Como comenté en la entrada anterior, JTS 1.11 trae algunas funcionalidades nuevas, que ya están aprovechadas desde los algoritmos de SEXTANTE correspondientes.

Esta información está incluida en el fichero readme.txt que acompaña a la versión diaria.

4 comentarios:

Agustin dijo...

Gracias Victor,
Me ha costado un poco encontrar el jtsio-1.11.jar por lo que pongo aquí el lazo
http://sourceforge.net/projects/jts-topo-suite/files/jts/1.11/jts-1.11.zip/download

Anónimo dijo...

Gracias por el enlace, Agustín

Anónimo dijo...

Gracias, tuve ese problema con Sextante (gvSIG 1.11 en Ubuntu 10.04), pero con la solución que das resolví, bajando el jts-1.11.zip del enlace que da Agustin, y de esa carpeta zip envié los archivos jts-1.11.jar y jtsio-1.11.jar al directorio que mensionas.
Saludos desde Valdivia, Chile.
p. dassori

Anónimo dijo...

He intentado hacer lo mismo que Anónimo, pero me deniega incorporar ambos ficheros al directorio. ¿Cómo lo hago?....todo esto ha empezado desde que instalé el gvsig 111 final, y me impide trabajar con sextante sobre un proyecto ya iniciado....¡ayuda por favor!